JAMF Pro - Standard: 11.24.1 Upgrade for us-east-2

Incident Report for Jamf

Resolved

This incident has been resolved.
Posted Feb 01, 2026 - 08:30 UTC

Investigating

Scheduled maintenance has been extended. Sorry for the inconvenience, we will provide updates as necessary.
Posted Jan 31, 2026 - 14:19 UTC
This incident affected: Jamf Pro - Standard (us-east-2: Jamf Pro - Standard).