Jamf School: Degraded Performance (EU-Central)
Incident Report for Jamf
Resolved
This incident has been resolved.
Posted Mar 27, 2024 - 20:30 UTC
Investigating
We are currently investigating this issue.
Posted Mar 27, 2024 - 20:09 UTC
This incident affected: Jamf School (eu-central-1: Jamf School).