Jamf Now - Device Communication Issue
Incident Report for Jamf
Resolved
This incident has been resolved.
Posted Apr 18, 2020 - 00:41 UTC
Investigating
We are investigating an issue that affects some customers and delays communication between managed devices and Jamf Now.
Posted Apr 18, 2020 - 00:20 UTC
This incident affected: Jamf Now.