Jamf Insights may not display mobile devices properly.

Incident Report for Jamf

Identified

The issue has been investigated. Development of a fix is underway.
Posted Sep 25, 2025 - 15:53 UTC

Investigating

Jamf Insights may not display mobile devices properly on the "Mobile devices" page. Devices might be missing from this view.
Posted Sep 24, 2025 - 16:59 UTC
This incident affects: Jamf Insights (Region: us-east-1: Jamf Insights Standard, Region: eu-west-2: Jamf Insights Standard, Region: us-east-1 Service-Enabled, Region: eu-west-2 Service Enabled).