Jamf Account Outage

Incident Report for Jamf

Resolved

The incident has been resolved
Posted Mar 19, 2025 - 17:47 UTC

Investigating

Jamf Account is currently inaccessible. We are investigating the issue.
Posted Mar 19, 2025 - 17:07 UTC
This incident affected: Jamf Account.