Jamf School: Degraded Performance (USE & EU)

Incident Report for Jamf

Resolved

Monitoring complete. No additional issues.
Posted Apr 02, 2026 - 21:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2026 - 15:37 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2026 - 13:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 02, 2026 - 13:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 02, 2026 - 12:53 UTC
This incident affected: Jamf School (eu-central-1: Jamf School, us-east-1: Jamf School).