Performance Degradation – SecureDNS (APAC)

Incident Report for Jamf

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 03:37 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 10, 2025 - 03:20 UTC

Investigating

Date/Time: 2025-12-10 01:30 UTC

We are investigating increased latency in SecureDNS policy evaluation for Jamf Security Cloud and Jamf Safe Internet in the APAC region. Customers may experience intermittent delays in DNS resolution.

Customer Impact: Partial service degradation; browsing or connectivity may be slower for affected users.
Affected Services: SecureDNS (Jamf Security Cloud / Jamf Safe Internet)
Affected Regions: APAC (ap-northeast-1)

Jamf Engineering is investigating and monitoring performance. Updates to follow. No customer action required at this time.
Posted Dec 10, 2025 - 01:53 UTC
This incident affected: Jamf Threat Defense, Jamf Private Access and Jamf Data Policy (Threat Defense, Data Policy).