The issue has been identified and a fix is being investigated. In the interim, identification and workaround instructions are detailed below.
Identification and Workaround: To identify which Mobile Device Smart Group may be affected, create a Jamf Pro summary (Settings > Jamf Pro summary) with the checkbox selected for Mobile Devices > Smart Mobile Device Groups. The resulting summary file can be searched for Device Ownership Type to find related smart groups.
Review the smart group configurations and ensure that any configurations relating to Device Ownership Type have a valid value. These valid values can be found in edit mode and clicking into the ellipsis ... and are also listed here:
Personal (Account-Driven User Enrollment) Personal (User Enrollment) Institutional Institutional (Account-Driven Device Enrollment)
If any other value not listed is inputted, the smart group calculation will include Institutional Device Ownership Type devices in the group membership.
Contact Jamf Support for questions or assistance.
Posted Mar 07, 2026 - 20:07 UTC
Investigating
An issue has been identified that is happening with Jamf Pro 11.25 where Smart Groups causes an invalid membership list when using criteria around Device Ownership Type and Personal Device Profiles. We are continuing to investigate at this time.
Posted Mar 07, 2026 - 18:39 UTC
This incident affected: Jamf Pro - Standard (ap-northeast-1: Jamf Pro - Standard, ap-southeast-2: Jamf Pro - Standard, eu-central-1: Jamf Pro - Standard, eu-west-2: Jamf Pro - Standard, us-east-1: Jamf Pro - Standard, us-west-2: Jamf Pro - Standard, us-east-2: Jamf Pro - Standard).