Jamf Pro - Degraded Performance - us-west-2 region

Incident Report for Jamf

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 17:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 16:39 UTC

Update

We continue to work on a fix for this issue.
Posted Mar 09, 2026 - 16:21 UTC

Identified

The issue has been identified and we are working on resolution.
Posted Mar 09, 2026 - 15:17 UTC

Investigating

We are experiencing performance issues within the US West 2 Region.  We are actively investigating this issue.
Posted Mar 09, 2026 - 13:58 UTC
This incident affected: Jamf Pro - Standard (us-west-2: Jamf Pro - Standard).