Jamf Security Cloud activations are being processed slowly in the European core data center.

Incident Report for Jamf

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 18:21 UTC

Monitoring

The older activation messages are now processed. The system is fully operational again. We are monitoring it further.
Posted Oct 01, 2025 - 17:07 UTC

Identified

The issue has been identified. The root cause has been fixed.
There are still a number of unprocessed activation messages which are now being worked through. This may cause delays in the processing of new JSC activation requests.
Posted Oct 01, 2025 - 15:28 UTC

Investigating

We are currently investigating this issue.
Posted Oct 01, 2025 - 15:25 UTC
This incident affected: Jamf Threat Defense, Jamf Private Access and Jamf Data Policy (Device Management).