Degraded Performance – DNS Requests and Device Enrollments in Tokyo Region

Incident Report for Jamf

Resolved

The earlier issue causing increased latency for DNS requests in the ap-northeast-1 (Tokyo) region has been resolved. Performance has returned to normal and all services are operating as expected.

We will continue to monitor closely. Thank you for your patience.
Posted Oct 02, 2025 - 05:28 UTC

Investigating

We are currently investigating increased latency affecting DNS requests in the ap-northeast-1 (Tokyo) region. All other JSC regions are operating normally. Our Secure Connectivity engineering team is actively working on the issue, but we do not have an estimated time for resolution at this stage.
Posted Oct 02, 2025 - 04:14 UTC
This incident affected: Jamf Threat Defense, Jamf Private Access and Jamf Data Policy (Threat Defense, Data Policy).