Jamf Security Cloud - Delay in Data Policy Change Propagation

Incident Report for Jamf

Update

We are continuing to investigate the issue.

Current Status: Jamf Security Cloud Policy Updates are unable to be saved. Previously changed configurations continue to see a propagation delay.
Posted Sep 10, 2026 - 16:52 UTC

Investigating

We are currently investigating an issue with Jamf Security Cloud that results in a delayed propagation of policy changes. Current configurations are working. If a policy change is made the updated configuration may not take effect immediately.
Posted Sep 10, 2026 - 16:05 UTC
This incident affects: Jamf Security Cloud (Data Policy).