Fulfillment services

Incident Report for Jamf

Resolved

All Jamf fulfillment services are fully operational.
Posted Sep 16, 2026 - 14:55 UTC

Update

We are continuing to investigate this issue.
Posted Sep 16, 2026 - 11:32 UTC

Investigating

Salesforce service Interruption is impacting all Jamf fulfillment services

Customer Impact:
• Affected Services: Provisioning, licensing, billing services, including Jamf Account services

Customer Actions: No customer action required at this time.
Posted Sep 16, 2026 - 11:31 UTC
This incident affected: Jamf School (ap-northeast-1: Jamf School, eu-central-1: Jamf School, us-east-1: Jamf School) and Jamf Account.