Jamf Protect for macOS - Degraded Performance

Incident Report for Jamf

Monitoring

A fix has been implemented and we are monitoring the results. Performance is expected to continually improve over the next several hours.
Posted Jun 23, 2026 - 20:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 18:38 UTC

Investigating

Incident Summary: Degraded Performance in Jamf Protect for macOS,

Customer Impact: Client machines may experience delays with retrieving configurations, plan updates and checking-in to Jamf Protect backend.

Status: The issue is under active investigation by our Engineering teams.

We appreciate your patience and are committed to resolving this as swiftly as possible.
Posted Jun 23, 2026 - 17:42 UTC
This incident affects: Jamf Protect (us-west-2: Jamf Protect).