Jamf School: Degraded Performance (EU-Central)

Incident Report for Jamf

Resolved

The interruption with Jamf School has been resolved. This issue effected read speed with our database. We apologize for any inconvenience.

Customer Impact: General slowness of Jamf School application in the European cluster.
Posted May 15, 2026 - 01:57 UTC

Monitoring

Normal operations has resumed. Monitoring will continue.
Posted May 15, 2026 - 01:01 UTC

Update

The process to resume normal operations is still in progress.
Users may continue to experience:
- Application slowness and performance degradation for customers using the European cluster
- Potential delays in request processing and page load times
Posted May 14, 2026 - 21:08 UTC

Identified

The issue has been identified, we've started the process to resume normal operations. Users may continue to experience:
- Application slowness and performance degradation for customers using the European cluster
- Potential delays in request processing and page load times
Posted May 14, 2026 - 15:13 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2026 - 14:54 UTC
This incident affected: Jamf School (eu-central-1: Jamf School).