Jamf Insights - Maintenance Window

Scheduled for May 23, 10:00 UTC  -  May 25, 10:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted May 21, 2026 - 10:38 UTC

Scheduled

We will be undergoing scheduled maintenance at this time.
Posted May 21, 2026 - 10:37 UTC
This scheduled maintenance affects: Jamf Insights (Region: us-east-1: Jamf Insights Standard, Region: us-east-1 Service-Enabled).